Extremely long delay when opening a Simulink model with UDP block (Instrument Control Toolbox)

109 views (last 30 days)
sven lack
sven lack on 11 Aug 2020
Edited: cui ungefär 15 timmar ago
Hi all,
I have the following problem: When I try to open a Simulink model with an UDP receive or send block (from the Instrument Control Toolbox) for the first time after starting Simulink, I have to wait over 30 minutes until the program show ready. After this first launch, I can work with the model without any problems. The problem still persists after reinstalling Matlab and Simulink. During the startup time, I can see in the task manager that Matlab is using 35 % of the CPU power. There are two processes from type "Java Chromium Embedded Framework (JCEF) Helper" and two from type "Matlab 2020a". I think it is a problem with the "Instrumental Control Toolbox" because I only have this problem when I use blocks from it.
Does someone else also have this problem and how can it be solved?
-----------------------------------------------------------------------------------------------------
MATLAB Version: 9.8.0.1323502 (R2020a)
Operating System: Microsoft Windows 10 Pro Version 10.0 (Build 18362)
Java Version: Java 1.8.0_202-b08 with Oracle Corporation Java HotSpot(TM) 64-Bit Server VM mixed mode
-----------------------------------------------------------------------------------------------------
Instrument Control Toolbox Version 4.2 (R2020a)
  1 Comment
VIJAY KUMAR DUBEY
VIJAY KUMAR DUBEY on 27 Jan 2021
I have got the same problem after simulation. Since matlab 2020 requires more than 8GB of RAM, the problem must be associated with the RAM. I hope after increasing the RAM of your system, the problem will automatically dissolved

Sign in to comment.

Accepted Answer

sven lack
sven lack on 19 Mar 2021
Hello and thanks for the answers but they don't solve my problem. I am now using Matlab 2020b on a computer with 16 GB of RAM, I7-7500U CPU and still the same problem. A simple model with just a UDP receive block takes 3 minutes to load (when I open it for the first time, if I close the model and open it again, it takes half as long). Java is up to date and I don't have prescan installed.
So, I think the best solution to the problem is to use udp blocks from other libraries (e.g. DSP toolbox). The same Model with a UDP receive block from the DSP toolbox takes less than a second to load on my system.

More Answers (3)

Jiajun Ma
Jiajun Ma on 2 Mar 2021
Hi Sven.
I have encoutered the same issue.
After updating my Java to latested version and reboot my computer.
The problem is solved.

Longfrei Bai
Longfrei Bai on 28 Sep 2021
I have the same issue with 2021b...

cui
cui ungefär 15 timmar ago
Edited: cui ungefär 15 timmar ago
R2022a have the same issue...
automated driving toolbox: driving scenaro app

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!