MATLAB Answers

emjey
0

Issue with SimBiology - parameters from valid .sbproj not loading

Asked by emjey
on 22 Aug 2019
Latest activity Answered by Arthur Goldsipe on 22 Aug 2019
Hi, I am having an issue pertaining to some *.sbproj models. See for example the attached simple Lotka model version.
While the general model information indicates that there are 3 parameters, 4 reactions, 4 species etc.
SimBiology Model - lotka
Model Components:
Compartments: 1
Events: 0
Parameters: 3
Reactions: 3
Rules: 0
Species: 4
the following commands
m1.Reactions
m1.Parameters
m1.Species
result in display of reactions and species arrays only
SimBiology Reaction Array
Index: Reaction:
1 x + y1 -> 2 y1 + x
2 y1 + y2 -> 2 y2
3 y2 -> z
ans =
0×1 empty double column vector
SimBiology Species Array
Index: Compartment: Name: InitialAmount: InitialAmountUnits:
1 unnamed x 1
2 unnamed y1 900
3 unnamed y2 900
4 unnamed z 0
The parameter array is empty!
What is wrong with the attached 'lotka.sbproj' file? Strangly enough the simulation runs just fine producing the expected results. I attach the simulation script as well.
Any comments would be very appreciated. M

  0 Comments

Sign in to comment.

Products

Communities

More Answers in the  SimBiology Community

2 Answers

Answer by Arthur Goldsipe on 22 Aug 2019
 Accepted Answer

As described here, parameters can be scoped to either the model or to a reaction. The display counts both scopes of parameters, but the model's Parameters property only lists model-scoped parameters. I agree that this difference is quite confusing! But there is a way to programatically get all parameters on a model using sbioselect:
allParameters = sbioselect(m1, 'Type', 'parameter')
-Arthur

  0 Comments

Sign in to comment.


Answer by emjey
on 22 Aug 2019

OK, problem solved.
This is to me a bug in the display of parameters - only those parameters which are visible on the diagram are also displayed as the 'Parameter Array'! (Unless of course I did something wrong and there is a way to find out all model parameters and display them.)
It would be useful this to be fixed as otherwiser one cannot programatically find out all the model parameters, using m1.Parameters, and e.g. assgn different values to them.

  0 Comments

Sign in to comment.