MATLAB Answers

Embedded coder generated code run on TI C2000 F28335 Ram well but not run on Flash

22 views (last 30 days)
omer cakmak
omer cakmak on 8 Feb 2019
Commented: Antonin on 11 Feb 2019
I am using MatlabR2017b , CCS7.4 and two different dsp , one of TI F28335PGF and the other one is F28335ZJA. I try simply blink a led via simulink blocks by using GPIO DO and one constant block. When I use F28335ZJA i can program both ram and flash,they work well but while try on F28335PGF , I can program ram but I can't program flash. In other words led is blinking when ram is used but led is not responding when i try "boot from flash" option. In order to do my project I need program both of the card via embedded coder. If you need more information please inform me, i can send anything about problem.
Note: On F28335ZJA I use GPIO 31 and GPIO 34 -- On F28335PGF I use GPIO 61
Could you please help me ?
Best regards,
Ömer

  0 Comments

Sign in to comment.

Accepted Answer

Antonin
Antonin on 8 Feb 2019
Hi Ömer,
Are you using different controlCards from TI?
Depending on the controlCard that you use, TI has placed crystals of different values.
For instance R1.1 (ZJZ), has a crystal of 20MHz while R1.0 (PGF) has a crystal of 30MHz.
This can be seen in the schematics for the different controlCards that you can find in controlSuite. On my machine here are the paths:
For R1.0: "C:\ti\controlSUITE\development_kits\~controlCARDs\CC2833xHWdevPkg\F28335controlCARD HWDevPkg PGF [R1.0]\F28335 PGF controlCARD Schematic.pdf"
For R1.1: "C:\ti\controlSUITE\development_kits\~controlCARDs\CC2833xHWdevPkg\F28335controlCARD HWDevPkg ZJZ [R1.1]\F28335controlCARD-Schem[R1.1].pdf"
You need to reflect the correct crystal value for your boards in the configuration parameters of your model under "Hardware implementation > Hardware board settings >Target hardware resources > Clocking > Oscillator clock (OSCCLK) frequency in MHz" and make sure that the "Achievable SYSCLKOUT in MHz" matches your desired CPU frequency (ideally 150MHz).
A wrong crystal value entered in the configuration parameters leads to the type of behaviors that you are describing.
Let us know if this helps,
Thanks,
Antonin.

  2 Comments

omer cakmak
omer cakmak on 11 Feb 2019
Dear Antonin;
Thank you for your quick response. Since I had some other problems at weekend, I tried your solution today and I blinked the led. As you suggest I changed my Oscillator clock (OSCCLK) frequency from 30 to 40MHZ (because my board has 40 MHZ) and it worked well, now I can run on both flash and ram.
Thanks
Ömer

Sign in to comment.

More Answers (0)

Sign in to answer this question.