Opening a simulink file that was saved in R2018b version onto a R2017b version.

92 views (last 30 days)
Hi guys, I have a Simulink file which was saved in the R2018B version of MATLAB, however, I only have access to the R2017B version of MATLAB. Is there any way for me to access the R2018b file? I do not have the R2018b version of MATLAB at all.

Sign in to comment.

Accepted Answer

Gavin Walker
Gavin Walker on 3 Dec 2018
Simulink has a preference, in the Model File section, called "Do not load models created with a newer version of Simulink". You can temporarily turn this off rather than edit the model files to change version numbers.
If the model uses only basic blocks then it might be possible to load it in R2017b, but it could also crash MATLAB. As others have commented, using the "Export to Previous Version" feature is the supported way to take a model from a later release to an earlier one.
Remember to turn the preference "Do not load models created with a newer version of Simulink" back on afterwards.
  1 Comment
Vaishnavi V
Vaishnavi V on 18 Oct 2020
Thank you, it worked, but it showed warnings, I tried to open 2018a version file in 2016a version, I turned off "Do not load models created with a newer version of Simulink", The file opened with several warnings. Then I it did not run and showed an error, due to the file conversion, Then I followed this thread, converting through online
In this I was able to convert to 2016a version and able to run in 2016a version without errors

Sign in to comment.

More Answers (3)

madhan ravi
madhan ravi on 14 Nov 2018
Edited: madhan ravi on 14 Nov 2018

Sign in to comment.

Gijs van Oort
Gijs van Oort on 20 Nov 2019
Be careful with this. I have some experience with very bad things happening. I don't remember which Simulink versions were involved in that (probably 2015/2016?), and I don't even remember if we tried to load the model into an older or a newer Simulink version.
The problem was that, in comparison blocks (comparing two inputs, and you could set the operator to be one of <, <=, ==, >=, >, != ), the wrong operator was chosen. So, when opened with one (the correct) version of Simulink, the block was a X<Y block, and when opened with the other version of Simulink, the block suddenly became a X==Y block (I don't remember which operators were involved, but you get the idea).
The worst part is that no error or warning message at all was generated.

HONG CHENG on 4 May 2022
You can follow this link and hope this can help you


Find more on Interactive Model Editing in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!