Clear Filters
Clear Filters

matlab does not start on Fedora 28

12 views (last 30 days)
I used Matlab 2018a with Fedora 27 Atomic Workstation and it worked fine. After the update to Fedora 28 Atomic Workstation, only the splash screen appears, when Matlab starts. Even a fresh installation of Matlab does not solve the problem. I tried to run Matlab 2018a on a normal Fedora 28 installation in a virtual machine. Matlab is not starting on Fedora 28, either.
Starting Matlab with logging enabled:
./matlab -desktop -logfile test3.log
leads to the following error in the log:
Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError:;)Ljava/lang/String;
at Method)
at com.mathworks.addressbar_api.AddressBarPluginManager.mapFriendlyPathToRealPath(
at com.mathworks.mlwidgets.explorer.util.MacEncodingBugWorkaround.i18nFix_mapFriendlyPathToRealPath(
at com.mathworks.mlwidgets.explorer.model.navigation.NavigationHistory$HistoryItem.<init>(
at com.mathworks.mlwidgets.explorer.model.navigation.NavigationHistory$HistoryItem.<init>(
at com.mathworks.mlwidgets.explorer.model.navigation.NavigationHistory.convertToHistoryItemArray(
at com.mathworks.mlwidgets.explorer.model.navigation.NavigationHistory.refreshFromPreferences(
at com.mathworks.mlwidgets.explorer.model.navigation.NavigationHistory.<init>(
at com.mathworks.mlwidgets.explorer.model.navigation.NavigationHistory.<init>(
at com.mathworks.mde.explorer.Explorer.buildAddressBar(
at com.mathworks.mde.explorer.Explorer.<init>(
at com.mathworks.mde.explorer.Explorer.createInstance(
at com.mathworks.mde.explorer.Explorer.getInstance(
at com.mathworks.mde.desk.MLDesktop.setCurrentFolderBarBelowToolstrip(
at com.mathworks.mde.desk.MLDesktop.restoreLayout(
at com.mathworks.widgets.desk.Desktop.restoreLayout(
at com.mathworks.widgets.desk.Desktop.restorePreviousLayout(
at com.mathworks.mde.desk.MLDesktop.restorePreviousLayout(
at com.mathworks.widgets.desk.Desktop.initMainFrame(
at com.mathworks.mde.desk.MLDesktop.initMainFrameFromThread(
at com.mathworks.mde.desk.MLDesktop.access$2100(
at com.mathworks.mde.desk.MLDesktop$
at java.awt.event.InvocationEvent.dispatch(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$500(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(
Starting matlab with
./matlab -nodesktop
works fine.
Francesco Brozzu
Francesco Brozzu on 21 May 2018
Same issue with Fedora 28 + R2018a, asked MATLAB support team and they simply said that this configuration is not supported yet.
Yu LIU on 3 Jul 2018
Same problem on me, Welcome frame hang on. Problem appears under both Fedora 27 and 28. By the way, R2017a, R2017b work fine under both Fedora.

Sign in to comment.

Accepted Answer

speedgo on 24 May 2018
1) dnf install libnsl
2) Use system libfreetype. Move bin/glnxa64/libfreetype* to another folder. See
I first get these errors with 'matlab -logfile log.txt':
Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError:;)Ljava
at Method)
This corresponds to the missing library libnsl required by
At Matlab installed folder:
$ ldd bin/glnxa64/
... => not found
After installing libnsl, I then get Matlab output dump: Segmentation violation detected. Work around on the libfreetype gets the matlab2018a running.
You might be missing different libraries that I've installed. Check out the libraries required by the .so files in Matlab.
Hope this helps. This issue was resolved quickly due to sending error report to Matlab, and they responded on the libfreetype workaround.
matse on 24 May 2018
Works great, thanks!
Andrew Naguib
Andrew Naguib on 19 Sep 2018
libnsl is not found [Fedora 27]

Sign in to comment.

More Answers (3)

Maximilian Galanis
Maximilian Galanis on 6 May 2018
I have the same problem on Fedora Workstation 28 and Matlab R2018a
  1 Comment
William ZHOU
William ZHOU on 22 Feb 2019
Same on R2018b, solved by following the accepted answer.

Sign in to comment.

SPHSC HelpDesk
SPHSC HelpDesk on 17 May 2018
We have the same problem here. Also with Fedora 28 and R2018a.

Conor Burgess
Conor Burgess on 24 May 2018
Please follow the instructions from this answer to solve a library loading issue between MATLAB and Fedora. Note that your MATLAB R2018a install path, e.g. ‘/usr/local/MATLAB/R2018a’, should be used instead of R2017b.
Then, for Fedora 28, you'll also need to install the ‘libnsl’ library. MATLAB looks for a version which is no longer shipped with Fedora 28, so needs to be installed manually. You can do this with the following command from a terminal prompt:
sudo yum install libnsl
  1 Comment
Luke Phillips
Luke Phillips on 3 Mar 2019
Conor, thanks so much for this solution, I was having the same issue with fedora 29 and matlab R2018b and libnsl installation fixed the problem.

Sign in to comment.


Find more on Introduction to Installation and Licensing in Help Center and File Exchange




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!