Why MATLAB R2023b requires macOS 12.6? Would 12.3 work?

2 views (last 30 days)
My production environment only has macOS 12.3 available, and it seems it can run MATLAB R2023b runtime sucessfully as well.
May I know what's the issue and fix requiring 12.6? Thanks.
  1 Comment
Dyuman Joshi
Dyuman Joshi on 19 Dec 2023
"May I know what's the issue and fix requiring 12.6?"
You will have to ask The MathWorks directly.
This is a forum where volunteers help with questions and queries related to the programming end of MATLAB.

Sign in to comment.

Answers (1)

Rik
Rik on 19 Dec 2023
Each Matlab release has a range of OS versions that are officially supported. This is only the official list. It is very well possible that newer or older OSes have no trouble running a specific Matlab version. Often even without any issue.
The reason why the list is limitted is that Mathworks essentially promisses that Matlab will work for those specific systems and provides installation support. For other OS versions it might work, but you will get no (or only limitted) support from Mathworks.
As an example: Matlab 6.5 (released 20 years ago) will run fine on Windows 11, only requiring a very small tweak. Windows XP is the latest version of Windows to be supported for that version of Matlab.
MacOS being what it is, you might have more trouble hacking together the system to get it working, but there should be no harm in trying.

Categories

Find more on Startup and Shutdown in Help Center and File Exchange

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!