Synthesis keeps on running for indefinite time on Xilinx RFSOC ZCU111

5 views (last 30 days)
I tried to validate the example "5G NR MIB recovery using Xilinx RFSOC ZCU111" and able to complete the steps before synthesis (i.e., the step-7). Once I started the synthesis operation, it keeps on running for indefinite time.
The vesrions of Vivado and MATLAb are 2020.1 and 2021b, respectively, which is as per the the following accepted answer: https://in.mathworks.com/matlabcentral/answers/518421-which-versions-of-xilinx-vivado-are-supported-with-which-release-of-hdl-coder#answer_426424
I will appreciate if someone can help on the same.
  2 Comments
John O'Sullivan
John O'Sullivan on 22 Sep 2022
I tried running synthesis using the same versions mentioned (MATLAB 21b and Vivado 20.1). I was able to generate a bitstream. It took around 2.5-3 hours from the Vivado external shell opening to generate a bitstream (synthesis + implementation + bitstream generation). I did notice that the external shell seemed to be stuck at some points, but pushing the return key seemed to get it to update with the latest output from the Vivado log.

Sign in to comment.

Answers (1)

Kiran Kintali
Kiran Kintali on 6 Oct 2022
Please reach out to support if you still run into this issue.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!