Mexw64 file not found in matlab foc example

2 views (last 30 days)
Hi,
I have been trying to run this example from matlab for FOC with a zynq evaluation board with my Linux PC. However, I see the following error when I tried to run the first task:
"Error in S-function 'focZynqTestBench/Motor_And_Load/motorAndLoadSFun_sfcn': S-Function 'motorAndLoadSFun_sf' does not exist"
After fighting with it for some time, I then switched to a laptop with windows OS, and I run the same example again. Then magic happens, it works without an error.
I am wondering if anyone could help to resolve the issue under Linux? Any suggestions would be highly appreciated! Thanks!
Best Regards,
Kelvin

Accepted Answer

Kiran Kintali
Kiran Kintali on 7 Oct 2022
The example ships mex files only for Windows. You need to have necessary products such as Simscape in place to rebuild mex on other platforms.
Feel free to reach out to support for additional help.
  1 Comment
KW YAN
KW YAN on 10 Oct 2022
Thanks Kiran for the help. This is very useful information to know!
Best Regards,
Kelvin

Sign in to comment.

More Answers (0)

Products


Release

R2022a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!