GPU MEX not compatible with GPU with compute capability '3.0'?

1 view (last 30 days)
Hi, I'm trying to set up the prerequisites for the GPU Coder. In the MATLAB Command Window, I entered:
gpuEnvObj = coder.gpuEnvConfig;
gpuEnvObj.BasicCodegen = 1;
gpuEnvObj.BasicCodeexec = 1;
results = coder.checkGpuInstall(gpuEnvObj)
and got the following results:
Compatible GPU : FAILED (The compute capability '3.0' of the selected GPU '0' is not supported by GPU Coder. Execution of the generated GPU MEX will not be available.)
CUDA Environment : PASSED
Runtime : PASSED
cuFFT : PASSED
cuSOLVER : PASSED
cuBLAS : PASSED
Basic Code Generation : PASSED
results =
struct with fields:
gpu: 0
cuda: 1
cudnn: 0
tensorrt: 0
basiccodegen: 1
basiccodeexec: 0
deepcodegen: 0
deepcodeexec: 0
tensorrtdatatype: 0
profiling: 0
My GPU is NVIDIA Quadro K420 (Driver version: 465.89, CUDA version 11.3). My questions are
  • Is there really no way to execute GPU Coder on my GPU? In the MATLAB documentations, I have not found descriptions about the requirement of the compute capability.
  • The result doesn't say it's impossible to generate the MEX code. Is it possible to generate the MEX code on my PC and then execute the generated code on a cluster node if the node is equipped with a better compute capability?
I appreciate any help.

Accepted Answer

Walter Roberson
Walter Roberson on 27 Mar 2022
Edited: Walter Roberson on 27 Mar 2022
  4 Comments

Sign in to comment.

More Answers (0)

Products


Release

R2020a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!