Clear Filters
Clear Filters

Installing MATLAB R2012a student version on OSX 10.10 does not work

1 view (last 30 days)
I am unable to install R2012a on OS X Yosemite. After Doubleklicking the "InstallForMacOSX"-file a MATLAB launcher window appears and then after some seconds it disappears. Nothing else happens. How can I install MATLAB 2012a on Yosemite?! those hints regarding the Java patch did not work, thats why I deleted MATLAB in order to re-install it. Thought this would help, now I can not even install it any more..
This is part of the installation try:
"Preparing installation files ... Installing ... Exception in thread "main" com.google.inject.ProvisionException: Guice provision errors:
1) Error in custom provider, java.lang.RuntimeException: java.lang.reflect.InvocationTargetException at com.mathworks.wizard.WizardModule.provideDisplayProperties(WizardModule.java:60) [...]"
I hope you can help me
  3 Comments
Lukas Steindorf
Lukas Steindorf on 31 Jan 2015
To install on Yosemite:
1) Check if you have Java SE 6 for x86_64.
From the Mac terminal, you can use this command to check:
/usr/libexec/java_home -V
If you don't have it, install it from http://support.apple.com/kb/DL1572
2) After calling the "/usr/libexec/java_home -V", note the directory where Java SE 6 is located. Mine was "/Library/Java/JavaVirtualMachines/jdk1.6.0.jdk/Contents/Home"
3) Find the install file from the Matlab installation directory. Drag it to your Terminal, insert a space, then type "-javadir", another space, then the directory where Java SE6 was. It should look something like this (on one line):
/Users/asdf/Desktop/mathworks_downloads/MATLAB2013/install -javadir /Library/Java/JavaVirtualMachines/jdk1.6.0.jdk/Contents/Home

Sign in to comment.

Answers (5)

Image Analyst
Image Analyst on 5 Nov 2014

Hao
Hao on 18 Nov 2014
I was struggling with the same issue for a while until I solved it by following the instructions below:
From the Finder's menubar, select "Go > Applications" to open the Applications folder (or open the folder that contains your copy of MATLAB). Select File > New Folder to create a new folder (it will be named "untitled folder"). Drag your copy of MATLAB into "untitled folder" Drag your copy of MATLAB back to its original location. Move "untitled folder" to the Trash.
Hope this would help.
  1 Comment
Lukas Steindorf
Lukas Steindorf on 31 Jan 2015
the problem is that MATLAB is not yet installed. so no file to rename and copy or anything. I open the installation file. It bootscreen pops up. closes again. thats it. nothing more happening

Sign in to comment.


Ndilokelwa Luis
Ndilokelwa Luis on 25 Jan 2015
Hi Lukas!
Where you able to solve the problem?
Thanks,
Ndilokelwa
  3 Comments
Image Analyst
Image Analyst on 31 Jan 2015
So what you're saying is that you called the Mathworks, and after having them work on it for 3 full months, they were unable to solve it for you. Surprising. I wonder how all those other people are using it on Yosemite then. If the Mathworks is really baffled and just threw up their hands and gave up, then it looks like your only option is to get a new version of MATLAB then. Ndilokelwa, is it the same problem with you, that the Mathworks is just totally unable to get it working for you?

Sign in to comment.


meshka
meshka on 27 Jan 2015
Edited: meshka on 27 Jan 2015
The response on the following link helped me fix my problem after upgrading to Yosemite. Maybe it can help you sort out your problem as well.
  2 Comments
Lukas Steindorf
Lukas Steindorf on 31 Jan 2015
Edited: Lukas Steindorf on 31 Jan 2015
this does not help me. I installed xquartz, I think it is just an extension to x11? however, after installing it I cannot find an Xquartz app... so I tried to type in the provided commands to the x11 terminal, but this seems only to work if MATLAB is already installed. For me it's just "no such file or directory found". I still cannot install it
Walter Roberson
Walter Roberson on 7 Aug 2016
Did you reboot or log out and log back in? You have to exit and reenter your login session for Xquartz to be found after you install it.

Sign in to comment.


Keenan Eure
Keenan Eure on 7 Aug 2016
have the same issue...this is of no help
  3 Comments
Walter Roberson
Walter Roberson on 7 Aug 2016
R2012a is not supported for Yosemite or El Capitan.
However, I have personally installed it on El Capitan so I am certain that it does work. I just followed the installation instructions that showed up when I requested the installer.
Lukas  Steindorf
Lukas Steindorf on 8 Aug 2016
Edited: Lukas Steindorf on 8 Aug 2016
Keenan Eure - have you checked the solution link which I posted at the top? I can't help any longer on this since I am now running the newest MATLAB and OS X El Capitan

Sign in to comment.

Categories

Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!