MATLAB Answers

JAGS 3.4 not recognised as command in MATLAB Win10

14 views (last 30 days)
I am currently trying to run the following package: which, according to the listed wiki requires JAGS 3.4 to run in MATLAB. I have previously gotten this to work on a Mac although need it to run on my PC running Windows 10 now.
When attempting to run the main function I am met with the following error:
Error using matjags (line 282)
Error from dos environment: 'jags' is not recognized as an internal or external command, operable program or batch file.
Going into the program files, I notice that the jags-terminal states the following:
Loading module: basemod: The specified module could not be found.
Loading module: bugs: The specified module could not be found.
Although I can find these modules in the relevant folder.
Does anyone know how to fix this? I have found the same error occurs when running JAGS 4.3 so I don't believe the version is the issue, and as it worked on a Mac before, neither is the MATLAB code. Perhaps windows is blocking access to the program?

Accepted Answer

Yongjian Feng
Yongjian Feng on 31 Aug 2021
It seems like an issue of the PATH env var? Try to set the PATH env var to point to those folders?
Yongjian Feng
Yongjian Feng on 1 Sep 2021
Accept the answer please if it works for you. Thanks.

Sign in to comment.

More Answers (0)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!