App Designer not Saving New Codes

37 views (last 30 days)
Hello Everyone,
My app designer is not saving new codes....It shows the * sign and when I save, it does not save the new code. I then have to shut down sometimes and the code still remains like the old code without the new code...Please advise me on what to do.
Jacek Jagosz
Jacek Jagosz on 9 Nov 2022
Edited: Jacek Jagosz on 9 Nov 2022
@Walter Roberson Thank you a ton for your reply! Unfortunately my problem actually seems to be different.
People who reported this issue were either using BTRFS file system or new kernel, and rolling back to older kernel fixed it. I am not using BTRFS, just standard EXT4. I also went back from Kernel 6.0 to 5.15, and the issue is the same. I also never got a single error message, like they did. That is what makes me thing this is a separate issue.
Edit: But the workaround with moving the TEMPDIR to somewhere else worked! So thank you for linking it for me. I know R2020b works just fine on my system, but R2022b is broken in this way. Hope Mathworks can figure out a way to fix their support for /tmp and tmpfs
Adam on 24 May 2023
I'm also having this same problem, for the 2nd time (in R2022b). I've only created two apps using App Designer in the last few years and both suffered from the same problem that they simply would not save (doesn't matter if I use Save or Save As).
First time I ended up having to re-create my App and saving worked that time, but it's frustrating after doing a bunch of work creating an app, that something as basic as Save simply doesn't work. I also submitted a ticket last time, but since I managed to work around it nothing really became of that.

Sign in to comment.

Accepted Answer

Shanmukha Voggu
Shanmukha Voggu on 6 Aug 2021
We are investigating the sources for the cause of not saving new code and even some times the save may be delayed especially for large files
The reasons may be
- If the app is large then tab completion in large files can delay the save
- Parsing the contents of the file to fill in App Designer's Code Browser
The team is investigating other sources as it appears there are more causes for this than just the two above and may be fixed in future releases
I recommend splitting out some logic from the main MLAPP into external M-files to reduce the size of the app.
Roberto Echeverria
Roberto Echeverria on 16 Feb 2022
Edited: Roberto Echeverria on 16 Feb 2022
Hello all,
I'm using 2021b, my app designer started to behave like this just today without any previous sign...
When i clic on save / save as it does nothing.
I clic on RUN, it tries to save and gets stuck doing nothing.
I clic exit, and if try to save it gets stuck.
Any update on this?
This problem has been solved for me especially when using R2021b. One method I used before it was solved was to save the app on a USB file and then run the app that way.
But contact Mathwork support and they will help you excellently.

Sign in to comment.

More Answers (0)


Find more on Startup and Shutdown in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!