Compiled DLL doesn't work on target machine

1 view (last 30 days)
I've built a DLL using the Matlab Compiler Toolbox, which I would now like to integrate into a Visual Studio project. Everything compiles nicely, but the program can not be started. Instead I keep getting the 'mclmcr.dll not found' error. I've tried just about anything I was able to find in the net (adding the compiler runtime path to the system path / reinstalling the compiler runtime provided in the Matlab compiler package).
My question: am I missing something? Might it be a problem, that the dll was built on a different machine (with the same architecture) from that where I'm trying to build the c++ project?
Any comments are very welcome!
Jan on 15 Aug 2013
Yes, I tried that but unfortunately it didn't make any difference...

Sign in to comment.

Accepted Answer

Jan on 15 Aug 2013
Edited: Jan on 15 Aug 2013
I managed to work around the problem by adding two entries to the system's path variable:
[Matlab Compiler Runtime Path]\[version]\bin\win32
[Matlab Compiler Runtime Path]\[version]\runtime\win32
I had tried that before, but had unfortunately added a space character after the semicolon following the previous entry. This obviously corrupted the variable in such a way, that no entry following the space character was included (a really avoidable mistake which took hours out of my time to figure out...)
However, it would be nice to know why changing the system's path variable was neccessary in the first place.

More Answers (1)

Stan on 1 Nov 2013
I noticed a similar problem (MATLAB R2013A 64bit). My program crashes when it calls the MATLAB function. Thread error: Clr20R3 (System.DllNotFoundException).


Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!