MATLAB Answers

Gauge widget refresh phenomenon

1 view (last 30 days)
Andreas Waldherr
Andreas Waldherr on 14 Feb 2021
Answered: Vinod on 18 Feb 2021
Hi!
In my channel (https://thingspeak.com/channels/1301128) i use a chart, a gauge and a nummeric display. All show the same data. Sometimes the Gauge shows 10 Volts (the minimum) the other two wigeds report the correct value. I have tested with Chrome, Edge and IE in there actual Versions. When I push reload to refresh the page it is reproducable in at least 1 of 10 times.
Whats wrong?
What can I do to work around this problem?
Any help is weolcome?
Thanks Andreas
  1 Comment
Christopher Stapels
Christopher Stapels on 15 Feb 2021
That is an intersting result. I appreciate that you called it a phenomenon, it definitely sounds more ecxiting that way. I would look at your gage update time (in the settings), and also make sure the page is refreshed and you are logged in. If you have a stale browser window that is logged out, the data may not be recent.
Would you say this issue is recent, or has it been ongoing for some time?

Sign in to comment.

Answers (1)

Vinod
Vinod on 18 Feb 2021
I suspect this is on account of a slow internet connection. The gauge needs to make a request back to the server to update its value. With a slow connection, that response time can be slow hence updating the gauge could be delayed.

Communities

More Answers in the  ThingSpeak Community

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!