Clear Filters
Clear Filters

Help needed with singularity in the solution?

39 views (last 30 days)
I hope this finds you well.
I am simulating a mathematical PV module that is connected to a DC-DC Boost Converter.
I keep getting this error message from the Diagnostic Viewer whenever I run my simulation.
'An error occurred while running the simulation and the simulation was terminated
Caused by:
  • Algebraic state in algebraic loop containing 'test123/Subsystem1/PV Module/PV Current/Add3' computed at time 0.0 is Inf or NaN. There may be a singularity in the solution. If the model is correct, try reducing the step size (either by reducing the fixed step size or by tightening the error tolerances) '
I tried to fix this issue by reducing the solver to take smaller time steps by changing the type to Variable Step and the Solver to ode45 (Dormand-Prince). Unfortunately, I am facing the same problem.

Answers (1)

Deepak Meena
Deepak Meena on 20 Nov 2020
Hi Yazan,
This message may be caused by a singularity in your system. One situation where this may occur is if the values of your states differ by a large magnitude. If this is the case, the Simulink solver will have a hard time resolving your step size within the error tolerance as it attempts to "bounce" back and forth between the states.
To check if this is the case:
1. Return the states of your system as follows:
a) In the model editor go to Simulation-> Configuration Parameters
b) Select Data Import/Export, in the 'Save to Workspace' field, check 'States' to log the states as output
2. Run the simulation.
3. Plot:
You can see if one of the states is changing over a wide range compared to the others.
There are a couple of things you can do to try to correct this situation. If possible, you may want to rescale the model so that the states are within a couple of orders of magnitude of one another.
Also, you can set specific error tolerances for the integrator blocks in your system. For more information, please refer to 'Specifying the Absolute Tolerance for the Block's Outputs' section in the Integrator block documentation by entering
doc integrator
at the MATLAB command prompt.
Other things to try:
Use a stiff solver (e.g. ode15s)
Decrease initial step size, maximum step size, and relative tolerance
Hope it helps
Thanks ,


Find more on General Applications in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!