Clear Filters
Clear Filters

Simulink trying to map struct to run-time parameter

23 views (last 30 days)
When attempting to run a function inside a Simulink model the simulation always fails due to the following error:
Unable to map parameter 'VarName' in 'FunctionName' to a run-time parameter. This parameter is an unsupported variable class such as a string, structure, cell, or an unsupported data type.
VarName is indeed a struct, but I do not understand why Simulink is attempting to make it a run-time parameter. VarName contains the initial conditions and online parameters used throughout the simulation. The Simulink model was built in 2013a and I am attempting to update it to run in 2017b. How can I prevent this error from occuring?
Thanks in advance.

Accepted Answer

Marshall Trout
Marshall Trout on 26 Aug 2019
Unsure what the actual cause was, but a windows update seems to have cleared up the error.
  2 Comments
Toheed Ghandriz
Toheed Ghandriz on 26 Sep 2019
I got the same error but it was solved after removing the check mark in front of 'Tunable' in Edit data dialog box for 'VarName'. My VarName was structure too.

Sign in to comment.

More Answers (1)

Noah Tang
Noah Tang on 28 Sep 2021
I was able to reproduce the same error message, and the comparison shows that the error happens when one field of my struct variable has an empty array as its value. Otherwise, the parameter passing process works just fine.

Categories

Find more on Simulink Coder in Help Center and File Exchange

Products


Release

R2017b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!