Model_X has multiple sample times error

59 views (last 30 days)
I am getting the following error
'MyTopLevelModel/SubsystemA/Model' has multiple sample times. Only constant (inf) or inherited (-1) sample times are allowed in function call subsystem 'MyTopLevelModel/SubsystemA'.
More info of my setup
SubsystemA has a function call which has a trigger port connected to a port set as "output function call with sample time of 0.001. All my other blocks have sample time -1 (inheritet).
If I go to the model explorer the compiled sample time are not [-1 0] some of the have set the [0.001 0]
Any idea what could be causing this error ?
  3 Comments
ricard molins
ricard molins on 20 Feb 2019
Can't share the model. Thats the reason I am asking for guidance of where could the potential error be and not a specific solution to my issue.
Arvind Sathyanarayanan
Arvind Sathyanarayanan on 20 Feb 2019
To identify which block(s) have a different sample time goto Display ->Sample TImes -> Colors.

Sign in to comment.

Accepted Answer

ricard molins
ricard molins on 22 Feb 2019
The problem was that a configuration reference had a time step set to 0.01. This time step was transformed into a CompiledTimeStep and therefore it set a CompiledTimeStep different to -1 or inf. Setting the time step to auto solved the issue.

More Answers (1)

dc
dc on 23 Apr 2023
it is very puzzle;you need configure the function call ‘s sample time in the runnable/system;i mean the display of f() . do not configure reference

Categories

Find more on Simulink in Help Center and File Exchange

Tags

Products


Release

R2016a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!