MATLAB Answers

Matlab R2016B Add-Ons Explorer / MATLABWindow command

7 views (last 30 days)
-=SrgiO=-
-=SrgiO=- on 18 Oct 2017
Answered: Jay Vaidya on 4 Sep 2020
Hello!
I have made several installations of Matlab r2016b with and without AUR script. With all the same result.
It works all correct ... including simulink, but I can not get the Add-ons explorer to work.
I've even tried it on Ubuntu 16.04 LTS and it works everything correctly. So I am still more motivated to get it in Arch Linux (I love!), specifically in the Manjaro distribution with XFCE.
I have corrected the symbolic links of the libraries pango and libfreetype as indicated in the wikiArch. I've even updated jxbrowser and everything stays the same. The Help explorer works, but the Add-ons Explorer still does not work, goes blank window.
To recreate the error and debug it, I use MATLABWindow that opens the window and loads (sometimes it is seen for a brief moment of time the page) and stays blank.
The messages in command window are as follows:
>> cd(matlabroot); cd bin/glnxa64; !./MATLABWindow -url=http://mathworks.com --disable-gpu
[1015/142141:ERROR:browser_main_loop.cc(203)] Running without the SUID sandbox! See https://code.google.com/p/chromium/wiki … evelopment for more information on developing with the sandbox on.
[1015/142142:WARNING:cefclient_gtk.cpp(49)] X error received: type 0, serial 309, error_code 8, request_code 42, minor_code 0
[1015/142220:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1
[1015/142220:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1
[1015/142220:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1
[1015/142220:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1
[1015/142220:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1
[1015/142220:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1
[1015/142220:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1
[1015/142220:WARNING:content_browser_client.cc(622)] No browser info matching frame process id 3 and routing id 1
[1015/150547:WARNING:cefclient_gtk.cpp(49)] X error received: type 0, serial 801, error_code 3, request_code 15, minor_code 0
Also, I tried "webutils.htmlrenderer('basic');" with the similar results.
I hope you can give me some idea and learn something more! Thanks!!!
System: Host: srgio-pc Kernel: 4.9.53-1-MANJARO x86_64 bits: 64 gcc: 7.2.0
Desktop: N/A Distro: Manjaro Linux
Machine: Device: laptop System: Hewlett-Packard product: HP Pavilion dv5 Notebook PC v: Rev 1 serial: N/A
Mobo: Quanta model: 3603 v: 02.26 serial: N/A
BIOS: Hewlett-Packard v: F.21 date: 08/20/2009
CPU: Dual core Intel Core2 Duo T9900 (-MCP-)
arch: Penryn rev.10 cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 12242
clock speeds: max: 3067 MHz 1: 800 MHz 2: 800 MHz
Graphics: Card: NVIDIA G96M [GeForce 9600M GT] bus-ID: 01:00.0
Display Server: N/A driver: nvidia tty size: 80x24
Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.9.53-1-MANJARO
Network: Card-1: Intel WiFi Link 5100 driver: iwlwifi bus-ID: 02:00.0
IF: wlp2s0 state: down mac: 12:cc:bf:9a:bf:ce
Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
driver: r8168 v: 8.044.02-NAPI port: 6000 bus-ID: 03:00.0
IF: enp3s0 state: up speed: 100 Mbps duplex: full
mac: 00:23:8b:5b:94:8b
Drives: HDD Total Size: 384.1GB (66.2% used)
ID-1: /dev/sda model: OCZ size: 64.0GB
ID-2: /dev/sdb model: TOSHIBA_MK3252GS size: 320.1GB
Partition: ID-1: / size: 51G used: 23G (48%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 9.05GB used: 0.01GB (0%)
fs: swap dev: /dev/sda2
Sensors: System Temperatures: cpu: 41.0C mobo: N/A gpu: 0.0:48C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 160 Uptime: 4:10 Memory: 1878.2/3923.9MB
Init: systemd Gcc sys: 7.2.0
Client: Shell (bash 4.4.121) inxi: 2.3.40

  2 Comments

Amy MacDonough
Amy MacDonough on 26 Oct 2017
Hi Sergio,
Are you able to install add-ons or hardware support packages by downloading them from the File Exchange?
Could you run these commands to see if you are able to open a CEF web window:
>> cefWindow = matlab.internal.webwindow('www.mathworks.com');
>> cefWindow.bringToFront
Your error messages include the line 'Running without a SUID sandbox!', have you tried following the steps on this webpage?
-=SrgiO=-
-=SrgiO=- on 8 Dec 2017
Hello!
After all this time, I have tried many combinations. Indeed, I can manually install the extensions.
Instead, the problem continues if I execute the commands that you have commented to me, the result is a white window. As with the command I used in the main post.
I'm really starting to think that the problem is about sandbox. What you think? The link about SUID Sandbox I've already seen it, but I do not know how to relate it to Matlab. It seems that it can be configuration problems or dependencies of the jxbrowser-chromium used by Matlab.
Thank you very much, as always.

Sign in to comment.

Answers (1)

Jay Vaidya
Jay Vaidya on 4 Sep 2020
Please try to run the following in the MATLAB Command Window:
>> opengl software
And then try opening the Add on explorer again. It worked for me.
If that works, you can save the preference so that MATLAB always opens with Software OpenGL by running:
>> opengl('save','software')

  0 Comments

Sign in to comment.

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!