right click 'open current folder in file manager' not working - Ubuntu/Linux

7 views (last 30 days)
Mark
Mark on 15 Oct 2017
Commented: Mark on 19 Oct 2017
Hi, when I right click in the 'Current Folder' view on the LHS of Matlab its supposed to open the file manager if I select 'open current folder in file manager' but it just does nothing.
Any ideas?
  9 Comments
Mark
Mark on 18 Oct 2017
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib/x86_64-linux-gnu/libmirclient.so.9)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/x86_64-linux-gnu/libmirclient.so.9)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib/x86_64-linux-gnu/libmircommon.so.7)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/x86_64-linux-gnu/libmircommon.so.7)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib/x86_64-linux-gnu/libmirprotobuf.so.3)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/x86_64-linux-gnu/libmirprotobuf.so.3)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /usr/lib/x86_64-linux-gnu/libmircore.so.1)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/x86_64-linux-gnu/libmircore.so.1)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/x86_64-linux-gnu/libboost_system.so.1.58.0)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/x86_64-linux-gnu/libprotobuf-lite.so.9)
nautilus: /usr/local/MATLAB/R2017b/sys/os/glnxa64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /usr/lib/x86_64-linux-gnu/libboost_filesystem.so.1.58.0)
>>

Sign in to comment.

Answers (1)

Prashant Arora
Prashant Arora on 19 Oct 2017
Hi Mark,
This issue is possibly caused due to dependency of MATLAB shipped "libstdc++.so.6" on GLIBCXX and CXXABI libraries, which are missing on your system. In general libstdc++.so.6 does not require these files and you should be able to workaround this issue by forcing MATLAB to use the shared library from your system, instead of the one shipped with MATLAB. To do this, use the following method:
1. Navigate to the following folder:
matlabroot/sys/os/glnxa64
which I believe is
/usr/local/MATLAB/R2017b/sys/os/glnxa64/
in your case.
2. Rename the file libstdc++.so.6 to libstdc++.so.6.old
This should resolve the issue that you are facing.
Hope this helps!
Prashant
  7 Comments
Mark
Mark on 19 Oct 2017
Hi Prashant, (I'm somewhat new to the structure of linux file system so bare with me please). I don't have /usr/lib64 only /usr/lib and in /usr/lib there is no libxml file.

Sign in to comment.

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!