Simulink real-time desktop kernel gone bad.

60 views (last 30 days)
I recently installed the simulink real-time desktop kernel on my laptop running windows 10. I installed it using MATLAB command window and the command sldrtkernel -install. Everything was working okay until one day I accidently closed Simulink + MATLAB while real-time desktop simulation was still running. After this day, I have been facing a big problem of the computer CPU being used 100% even when I am not using MATLAB/SIMULINK. The computer fan runs at top speed all the time even if I do nothing on my computer. I think the problem is with real-time desktop kernel. How do I get my CPU back running as it used to do normally (of course without having to re-install/repair windows 10)?
Roshan Sharma
Roshan Sharma on 7 Feb 2017
Hi Jordan, like Patrick Busch has commented, the process using the CPU is changing all the time. The only solution that worked for me was "not" to use the real-time sync and the real time kernel. There a file in mathwork exchange called "real-time pacer for simulink". This worked well for my purpose which is to read/write data to NI-USB 6003 along with the MPC block from Model predictive control toolbox. Here is the link:

Sign in to comment.

Accepted Answer

Jan Houska
Jan Houska on 10 Feb 2017
Hi, this is Jan from Simulink Desktop Real-Time development.
The problem with 100% CPU utilization has no direct relation to the real-time kernel. It is because of misconfigured power scheme. Simulink Desktop Real-Time temporarily boosts CPU performance to 100% to ensure the fastest possible sample rate. Under normal circumstances, this gets restored back to the normal values when the real-time experiment finishes. However, if the real-time experiment ends abnormally (like MATLAB process killed from task manager or such), the power scheme does not get restored and remains set to maximum CPU performance.
For an immediate solution, the only advice I can give at the moment is to change to a different power scheme. That is, if your current power scheme is e.g. set to Balanced, set it to e.g. High Performance (or vice versa - just change it to something different). This should get the CPU utilization back to normal.
I understand that this is a temporary workaround and the issue should be fixed in some more robust way. And, there should be a way to fix the misconfigured power scheme without the need to switch to another one. I don't have a better solution right now, but the problem is being investigated and a better solution is on the way.
And, finally, a wish: please do report such issues via technical support. This ensures that development is notified and can respond in a much shorter time than I was able in this case.
Thanks, Jan
Ajpaezm on 26 Dec 2018
Hello Jan,
I've been encountering this issue in version 2018a, don't know why is this. Is there an article or advice I can use to solve this issue?
I already tried resetting to default the Energy Saving Options. But that didn't get me anywhere, unfortunately.

Sign in to comment.

More Answers (2)

Camile van der Heijden
Camile van der Heijden on 3 Apr 2017
As Jan Houska explained, the problem seems to be with the windows power plans that get 'corrupted' after a abnormal exit from matlab/simulink while using the real time kernel. Restoring the default settings for the affected power plan worked to solve the problem for me. (On windows 10, assuming you're currently using the affected plan go to: Start Menu > 'Edit Power Plan' > 'Restore defaults for this power plan'). So no need to switch to a different one (which is nice, because I like to continue using the balanced plan.)

Hakan on 12 Dec 2017
Here you will find the solution :
Best regards, Hakan

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!