Error in MuPAD command: .

7 views (last 30 days)
Roy Sarkis
Roy Sarkis on 29 Nov 2023
I had Matlab 2021b and I used to use 'syms a b c' to create symbolic variables and it worked perfectly. Today I started getting the following error
Error using mupadmex
Error in MuPAD command: .
Error in sym>tomupad (line 1486)
S = mupadmex(numeric2cellstr(x));
Error in sym (line 249)
S.s = tomupad(x);
Error in syms (line 231)
defined = sym(zeros(1, length(args)));
I tried the following commands:
>> which -all syms
/Applications/MATLAB_R2023a.app/toolbox/symbolic/symbolic/syms.m
>> which -all sym
/Applications/MATLAB_R2023a.app/toolbox/symbolic/symbolic/@sym/sym.m % sym constructor
Additionally, I also tried
restoredefaultpath; rehash toolboxcache; savepath
If I run the following:
status = license('test','symbolic_toolbox')
I get a status = 1
And I still get the same error. I have a macbook Pro M1 Max and using Matlab R2023a. Any ideas how to fix this?
  5 Comments
Roy Sarkis
Roy Sarkis on 29 Nov 2023
Edited: Roy Sarkis on 29 Nov 2023
I do agree and i saw the requirements. I actually had R2021a and it was working before upgrading to MacOS Sonoma. Today (after some time from using matlab and after updating to Sonoma) I tried to run 'syms a b c' and it didnt work. I then upgraded to Matlab R2023b which should be supported on Sonoma https://ch.mathworks.com/support/requirements/matlab-mac.html but i still get the same error. Thats why i tried going back to previous versions but i still get the same error
Venkat Siddarth Reddy
Venkat Siddarth Reddy on 14 Dec 2023
Did you execute the above commands, after upgrading your MATLAB to R2023b?
These errors might be due to search path issues or/and file shadowing issues that occured after you updating your MATLAB release.

Sign in to comment.

Answers (0)

Tags

Products


Release

R2023a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!