Clear Filters
Clear Filters

MATLAB Runtime を含めてコンパイルし​ようとすると、「この​ファイルは、このバー​ジョンの MATLAB で有効な MATLAB Runtime インストーラーではあ​りません」のエラーが​発生するのはなぜです​か?

13 views (last 30 days)
MATLAB Compiler のアプリケーションコンパイラにて、"ランタイムをパッケージに含める"を選択して、MATLAB コードをコンパイルしようとしました。
既に、MATLAB Runtime はダウンロードし、[設定]ダイアログにて、MATLAB Runtime インストーラーの場所も指定しましたが、コンパイルすると、以下のエラーが発生します。
「このファイルは、このバージョンの MATLAB で有効な MATLAB Runtime インストーラーではありません。」
どのように解決すればいいか、教えてください。

Accepted Answer

MathWorks Support Team
MathWorks Support Team on 8 Aug 2023
Edited: MathWorks Support Team on 8 Aug 2023
MATLAB のバージョン名については、「MATLAB R2023a Update4」のように、リリース部(R2023a)と Update 部が合わさっています。弊社 Web サイト から MATLAB Runtime をダウンロードすると、選択したリリースの最新 Update に対応したものが取得されます。
MATLAB Compiler でコンパイルしたアプリケーションについて、確実に立ち上げて動作させるためには、アプリケーションをコンパイルした MATLAB におけるリリースと Update に対応した MATLAB Compiler のインストールが必要になりますのでご留意ください。例えばアプリケーションが R2023a Update 4 でコンパイルされたならば、R2023a Update 4 の MATLAB Runtime が必要になります。
前記のように
 では各リリースの最新 Update のみが配布されています。もし最新以外の Update が必要な場合は、対応するバージョンの MATLAB から下記コマンドを入力して、当該 MATLAB Runtime のダウンロードアドレスを入手してください。
>> com.mathworks.toolbox.compiler.MatlabRuntimeUtils.getMCRInstallerDownloadURL()

More Answers (0)

Tags

No tags entered yet.

Products


Release

R2019a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!