Clear Filters
Clear Filters

How can I fix the "Failed Factorial design specification" ?

37 views (last 30 days)
Dear all,
I am trying to conduct a two-way ANOVA analysis of task fMRI using SPM12 and MATLAB software version R2020a and facing a problem.
Failed 'Factorial design specification'
Error using save
Found characters the default encoding is unable to represent.
In file "/Users/haiti/Documents/MATLAB/spm12/config/spm_run_factorial_design.m" (v7739), function "spm_run_factorial_design" at line 1062.
=> line 1062: save('SPM.mat', 'SPM', fmt);
What would you recommend to fix it ?
Thank you very much for your time and consideration, highly appreciated!
Sincerely,
Haiti
  2 Comments
Jules
Jules on 17 Oct 2022
Hey Hai-Ti,
TL;DR: I switch back from MATLAB2022a to MATLAB2018b to avoid the error.
Long response :
have you found a solution?
I just run in the same problem but I could not find any response on this issue...
I have tried to manually edit the SPM code to switch
save('SPM.mat', 'SPM', fmt);
to
save('SPM.mat', 'SPM');
I had to do it in several places (in four or five files so far) and It seems to remove the error message ... I just hope it will not affect the SPM processing...
edit: and unfortunelty it does affect and block the normal SPM processing. Saving files seems fine but eventually spm12 use some compiled non-MATLAB file that I couldn't track and adjust to solve the issue ...
So I revert my matlab to an older version to make everything run as it uses too.

Sign in to comment.

Answers (3)

Esteban
Esteban on 3 Mar 2023
Hi, all
I have this problem. How did you solve it? It is taking me a lot time trying solve it.
Thanks a lot!
Best regards,
Esteban

Kseniia
Kseniia on 11 May 2023
Hi!
If your main language is not English try to check if there are any non-latin characters in pathes where your contrasts or any other loaded files are stored.
Final SPM.mat store all full pathes inside and it could be the place your "characters the default encoding is unable to represent" are.
P.S. I had the same problem and changing all names to latin alphabet helped me.

Bényei Gábor
Bényei Gábor on 26 Sep 2023
There is solution!
Install a bit older version of Matlab, e.g. 2019a, it will allow saving. (Worked for me)

Categories

Find more on Data Import and Network Parameters in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!