Facing problem in Motor & Drive (System Level)

8 views (last 30 days)
Jay Talreja
Jay Talreja on 25 Apr 2022
Commented: Jay Talreja on 4 May 2022
Hello,
I am working on electric vehicle simulation. I am using Motor & Drive(System Level) block from Physical library. I have the data of electric motor required and I am trying to simulate vehicle performance.
I have never used Motor & Drive (System Level) so this is my first time. My problem is that when I trying to simulate the model I am facing one problem. I have attached the screenshot of the data. I am not sure how to solve the problem. I have followed the rules of building the data as shown in Generic motor and drive with closed-loop torque control - MATLAB - MathWorks India.
I cant upload the whole model but I am attching the relevant data in mat file for the motor for reference and the motor how I am working on it.
And I also wanted to ask if anyone have idea on how to calculate PowerLoss of motor. Currently I am using Pl = (2*pi*N*T/60)*(1 - e/100) correct me if I am wrong. I dont have voltage and current data.
Kindly share the solutions to this problem.
Thanks in Advance

Accepted Answer

Dakai Hu
Dakai Hu on 29 Apr 2022
Hi Jay,
Thanks for your questions.
There are a couple of issues in your attached model.
  1. The Motor & Drive block must be connected to a DC source. In your model they are shorted together.
  2. The Motor & Drive block only takes in row vectors. You can transpose all the column vectors in MATLAB workspace, or do it in the block's parameter fields, such as below:
  1 Comment
Jay Talreja
Jay Talreja on 4 May 2022
Thanks Dakai,
I have made the required changes and it works as expected.

Sign in to comment.

More Answers (0)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!