Error when using Simulink: "slCustomi​zer.static​Refresh" unrecognized field name "obj" on Mac

80 views (last 30 days)
I started using Matlab R2021b + Simulink a couple of days ago on my Mac. I used it in multiple projects and it was working fine.
Now I am having some problems when using Simulink. When starting I get the following message in the Command Window combined with a refresh of my Simulink Menubar:
caught exception in slsvXtesterFEVALWithDeferredCtrlCHandling.
It happens nearly every time I try to do anything in a existing or blank model (I can't open the Modelsettings - they crash too). It's quite unusable this way.
I tried to reinstall Matlab + Simulink without success. I also tried:
restoredefaultpath
rehash toolboxcache
Which did not fix the problem. I tried to run:
sl_refesh_customizations
This resulted in a more specific error:
An error occurred during Simulink customization.
[...]
Caused by:
Error using slCustomizer.staticRefresh
Unrecognized field name "obj".
Does anyone have an idea on how to fix this problem?
Thanks
  4 Comments

Sign in to comment.

Accepted Answer

Ananya Tewari
Ananya Tewari on 21 Oct 2021
Hello,
This issue can be caused by a sporadic corruption of a file related to data dictionaries associated with libraries.
On your machine, please go to the MATLAB "prefdir" and then navigate into a directory called "SLLibraryLinkageData". This directory should contain a MAT file named "LibraryLinkageCache.mat". Please delete this file and restart MATLAB.
  3 Comments

Sign in to comment.

More Answers (0)

Products


Release

R2021b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!