MATLAB Answers

Old-version simscape model cannot run on MATLAB 2020

4 views (last 30 days)
Randy Chen
Randy Chen on 12 Sep 2021
Commented: Randy Chen on 18 Sep 2021
I downloaded a 2017-version simscape model and attempted to run it on MATLAB 2020, but it keeps giving me this error:
I tried resaving this simscape model in my 2020-version MATLAB, but it doesn't work. I have simscape and simscape model body, etc, installed properly already.

Answers (1)

Swetha Polemoni
Swetha Polemoni on 15 Sep 2021
Hi,
The error is because Simscape no longer supports use of first-generation functions and blocks in 2017, so it cannot find the library mblibv1 .
As a workaround, you can do any of the following
  • Run files in 2019b or earlier versions
  • Update the model using blocks from Simscape Multibody Second Generation Library (sm_lib).
  • Use Simscape Multibody 1G Conversion Assistant tool to build Simscape Multibody 2G model that provides same behavior as 1G model.
  1 Comment
Randy Chen
Randy Chen on 18 Sep 2021
Hi,
Thank you for your reponse.I tried using the conversion assistant, but the conversion assistant is not detecting any 1-G model, so the newly-generated "2g" model is blank.
How can I update my current model using the Second Generation Library? I can't find it in Simulnik

Sign in to comment.

Tags

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!