Main Content

Run a Dependency Analysis

Note

You can analyze only files that are in your project. If your project is new, add files to the project before running a dependency analysis. See Add Files to the Project.

To investigate dependencies, run a dependency analysis on your project. On the Project tab, in the Tools section, click Dependency Analyzer. Alternatively, in the project Views pane, select Dependency Analyzer and click Analyze.

To analyze the dependencies of specific files, in the dependency graph, select the files. In the Impact Analysis section, click All Dependencies or use the context menu and select Find All Dependencies.

To analyze the dependencies inside external toolboxes, select Analyze > External Toolboxes. For more details about available options, see Analysis Scope.

You can also check dependencies directly in Project. In the Project Files view, right-click the project files you want to analyze and select Find Dependencies.

After you run the first dependency analysis of your project, subsequent analyses incrementally update the results. The Dependency Analyzer determines which files changed since the last analysis and updates the dependency data for those files. However, if you update external toolboxes or installed products and want to discover dependency changes in them, you must perform a complete analysis. To perform a complete analysis, in the Dependency Analyzer, click Analyze > Reanalyze All.

Note

In the Simulink® Editor, if an open model, library, or chart belongs to a project, you can find file dependencies. On the Simulation tab, select Project > Run Dependency Analysis. Simulink analyzes the whole project and shows all dependencies for the file.

For next steps, see:

Tip

To try a dependency analysis on example files, see Perform Impact Analysis with a Project.

Related Topics