Clear Filters
Clear Filters

Simulink can not be Opened

10 views (last 30 days)
Py L
Py L on 23 May 2021
Commented: Bharat Bohara on 2 Jul 2022
My MATLAB is 2019B and my license is an academic license. I can't open Simulink in my computer. When I click "Simulink" or input "simulink" into MATLAB command window, there is no any phenomenon that appears, even an error hint window. It just like that I have not done anything about Simulink. But when I close MATLAB, it will hint me that there is a current executing task. I can't find the reason.I have installed JDK. Although I have reinstalled MATLAB, the problem still appears.

Answers (1)

Uday Pradhan
Uday Pradhan on 26 May 2021
I understand that you are unable to open Simulink and it is unresponsive. The initial troubleshooting steps you can attempt when facing issues of this nature are to restore your search path as a corrupt search path can often cause startup issues.
Here are the steps to follow:
Before modifying the search path, it is important to take a backup of your 'pathdef.m' file, which can be located by using the command:
which -all pathdef
Before proceeding, ensure that you make a safe copy of the file by copying it to a folder outside of your MATLAB path.
After taking the backup, please execute the following commands in the MATLAB Command Window to restore the default MATLAB search path and rehash the toolbox cache:
NOTE: This will remove any custom paths you may have created. The following MATLAB Answers post is an additional resource on how to back them up:
rehash toolboxcache
After this step, please use Simulink to see if the issue occurs again. If the issue is resolved, then you may want to save the new MATLAB search path by executing the following command:
If this does not fix the issue, please contact Support.
Py L
Py L on 30 May 2021
Thank you for your answer. But I'm sorry that I have tried on your method but it didn't work. Now the situation is: I have suspected that the problem is due to a want of updates and then I installed MATLAB 2020B. I tried on this method in 2020B. When I ran "restoredefaultpath" and "rehash toolboxcache", the command could be completed as expected. But when I ran "sl_refresh_customizations", it didn't work and became unresponsive just like Simulink.
Bharat Bohara
Bharat Bohara on 2 Jul 2022
Thanks this helped.

Sign in to comment.


Find more on Startup and Shutdown in Help Center and File Exchange





Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!