troubles loading Simulink operating point

7 views (last 30 days)
Brian Tremaine
Brian Tremaine on 27 Jul 2019
Commented: Anirudh Singh on 31 Mar 2020
I am trying to save and restore an operating point in Simulink R2019a. This is a feature I'm just starting to use.
I used the following to run my model and get the operating point:
simOut = sim('bldc_simple', '0.8')
myOperPoint = simOut.myOperPoint
This seemed to have worked and generates a structure myOperPoint.
Next, I updated the Configuration --> load from Workspace to add myOperPoint as the initial conditions.
Now I use the following to run some longer time:
tic
bldc_simple
% set_param('bldc_simple','SaveFinalState','on','LoadInitialState','on',...
% 'InitialState','myOperPoint','FinalStateName','myOperPoint2',...
% 'SaveOperatingPoint','on');
% load myOperPoint in Configuration
set_param('bldc_simple','SaveFinalState','on',...
'InitialState','myOperPoint','FinalStateName', 'myOperPoint2',...
'SaveOperatingPoint','on');
simOut = sim('bldc_simple','StopTime','1.3') ;% <------ line with error
myOperPoint2 = simOut.myOperPoint
elapsedTime = toc
save('temp.mat');
Now I get an error:
Error using batch (line 14)
,The width of the given MATLAB array does not match that of the Simulink internal data
What am I missing? The error description is cryptic. Thanks !!!
  1 Comment
Anirudh Singh
Anirudh Singh on 31 Mar 2020
Did you apply this:
"Before you save the operating point, disable the Block Reduction parameter in Configuration Settings > Simulation Target > Advanced Parameters."
I am attaching a documantation page of save and restore operating point in simulink, check if you miss any step:

Sign in to comment.

Accepted Answer

Florian
Florian on 27 Jan 2020
Hi Brian,
did you solve your problem? I got the same error message.
cheers
Florian

More Answers (0)

Products

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!