Clear Filters
Clear Filters

Installing Lightspeed on R2017b

4 views (last 30 days)
Evangelos Mitsokapas
Evangelos Mitsokapas on 15 Jan 2018
Answered: Chetanya on 16 Aug 2018
Hi all, I have been trying to install the Lightspeed toolbox on R2017b. Actually it is literally the first time I am trying to install an add-on to Matlab therefore I had to go through step by step. However, I have the following error once I try to execute the install_lightspeed:
libmwlapack.lib was not found. To get additional optimizations, paste its location into install_lightspeed.m
mex -largeArrayDims -silent -DBLAS64 solve_triu.c "C:\Program Files\MATLAB\R2017b\extern\lib\win64\mingw64 \libmwlapack.lib" "C:\Program Files\MATLAB\R2017b\extern\lib\win64\GNU\libmwblas.lib"
Error using mex
gcc: error: C:\Program Files\MATLAB\R2017b\extern\lib\win64\GNU\libmwblas.lib: No such file or
Error in install_lightspeed (line 116)
eval(['mex' lapackflags ' solve_triu.c "' lapacklib '" "' blaslib '"']);
I have tried to go into the script and replace the location of the 'libmwlapack.lib' but then I received the same error. I have loaded the MinGW-w64 Compiler and I have tried everything.
Could someone please guide me through on how to solve this? Also, I am not familiar as how to use the package once it is installed. Should I load something or is it by default applied to the functions?

Answers (2)

Darshan Ramakant Bhat
Darshan Ramakant Bhat on 17 Jan 2018
Lightspeed toolbox is not the toolbox provided by MathWorks. Please note that MathWorks is not responsible for any kind of use and distribution of files from MATLAB Central. Please contact the author of the file if you have any questions or need more information.
However, I found the similar issues is being discussed in the below MATLAB answer post:
  1 Comment
Evangelos Mitsokapas
Evangelos Mitsokapas on 18 Jan 2018
Hello and thank you for your answer. I also have found this thread, since I searched online before posting a question here, but it seems that it does not respond to my question, only describing part of the problem. Moreover, I am aware that Lightspeed is not a MathWorks toolbox, but I could not help but wonder if people who use Matlab could provide a bit more info with regard to this.

Sign in to comment.

Chetanya on 16 Aug 2018
|Hi, The problem is due to the fact that mex is unable to recognise the paths given at the end of line 116 and 117 due to formatting.
A simple fix such as commenting the line 116 and 117 and pasting the following code should do the trick.|
mex -largeArrayDims -silent -DBLAS64 solve_triu.c "C:\Program Files\MATLAB\R2017b\extern\lib\win64\mingw64\libmwlapack.lib"
mex -largeArrayDims -silent -DBLAS64 solve_tril.c "C:\Program Files\MATLAB\R2017b\extern\lib\win64\mingw64\libmwlapack.lib"


Find more on Introduction to Installation and Licensing in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!