MATLAB Answers

Matlab startup hangs

8 views (last 30 days)
Fred on 30 Nov 2011
Commented: Miriam on 21 Feb 2020
I've had this problem on both a MacBook and a MacBook Pro. Today, it is a nice fresh install of Matlab_R2011b on my relatively new and uptodate MacBook Pro. When I try to start up Matlab, it starts the X server, gets part of the way there, and then hangs. In the menu bar, I see "Matlab", but no further menus, and no window. In /var/system.log, I see:
StartMATLAB[0]: 2011-11-30 14:46:29.899 MATLAB[21854:617] Process manager already initialized -- can't fully enable headless mode.
The Matlab icon is present, the dock tells me matlab is running, but no window appears.
I used to get this on a MacBook running R2007b. I used to work around it by closing everything I had open, restarting, and launching Matlab as the first programme. I am no longer willing to do that, as it costs me about an hour each time, and I lose track of my work in dozens of other programs.
Is there a way around this infuriating glitch? Help greatly appreciated.

Answers (2)

Thomas on 30 Nov 2011
As far as I know, MATLAB R2011b does not initallize the X Server on MATLAB as it used to do upto R2010a . Are you sure you are opening the correct MATLAB version and not the old version.
Try intiallizing matlab from terminal:
cd /Applications/ ./matlab
  1 Comment
Miriam on 21 Feb 2020
Worked for me for MATLAB 2019b after trying all kinds of things including upgrading from 2018b. Thanks a bunch. I removed the older version and also put the new on in /Applications. But this was the only thing that worked after all that. It is no longer "not responding" or hanging.

Sign in to comment.

Fred on 30 Nov 2011
Fixed. The installation assured me it was removing the old version, but it seems not to have done so! And the new one doesn't use X11.
Many thanks!

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!