Clear Filters
Clear Filters

Conflict between slx models and explorer in Windows 7

1 view (last 30 days)
This has started really suddenly. I do not know what has changed. I suddenly have some kind of massive conflict between windows 7 explorer, and relatively large (0.3MB or more) simulink library models (libraries).
The symptom is that in explorer if you try to do anything with these files (delete, copy, paste, access properties) it hangs the explorer window(s) using 100% of 4 cores, and the dreaded green progress bar of doom at the top. It takes perhaps 10 minutes to clear.
Specifically, I have slx library 2 files named something like "Roscoe_xxx_lib.slx" which have become almost unusable in Explorer today. Smaller slx files (models not libraries) do not seem to be affected. I thought I had some kind of virus or problem with windows indexing but I have tried everything with no effect.
EXCEPT, if I open Simulink without explorer, and manage to convert them back to the old ".mdl" extension, MATLAB renames the .slx as .slx.r2014. Now, I can copy, paste, move, delete those .mdl files without any problem.
I'll stress, there appears to be nothing wrong with MATLAB or Simulink. It is just some kind of really wierd interaction between those .slx libraries and explorer. You just can't move/copy/paste/delete them in explorer without minutes or hours of wait.
Any ideas? I notice that slx files seem to show some kind of thumbnail in explorer at the bottom when you click on them, even when you are in "Details" view. I see lots of web postings about windows 7 explorer hanging with media files with the green bar of death. Perhaps this is related to the "large" >0.3MB slx files?
Andrew Roscoe
Andrew Roscoe on 14 Aug 2014
I.T. have scanned my PC with an anti-malware tool and found nothing. I don't see the issue on other win7 64-bit machines. It must be some setting, update, or other installed program on this PC that is making explorer go so crazy about these large slx files. The problem PC is the only one with MATLAB R2014a on it, but the problem is certainly NOT related to slx files generated with r2014a. I see the same problem (or not) on all PCs with different slx files generated by r2014a and r2012x.
I found out that the slx file can be opened by a zip extractor like 7-zip to see the component parts. If you rename it to .zip you can also open it with windows' own native zip application. I am wondering if explorer is trying to do something like unzip these slx files and look inside. With small ~50kB slx files I seem to have no problem. But the big libraries are >300kB and one is ~1MB. Perhaps explorer is trying to extract all the files and examine all the content, and getting confused somehow?
I anyone has any ideas I would be very grateful!
Tobias Rief
Tobias Rief on 27 Oct 2014
I have the same problem on a win7 64-bit pc and Matlab 2014a. I wanted to copy the model to a new project in order to use it as a skeleton for the new project. Copying the model file is not possible because the explorer hangs and needs to get restarted. Accessing the file through the command window though is possible. So I renamed the file and copied it afterwards using the explorer. That does not cause any problem. So this seems to be a problem with the file ending...

Sign in to comment.

Answers (4)

Hamidreza Zamani
Hamidreza Zamani on 4 Sep 2014
Edited: Hamidreza Zamani on 4 Sep 2014
I have the same issue. The problem did not exist and began suddenly maybe when the size of the Simulink model increased and passed some threshold. I have installed student version of Matlab and SImulionk on a 64-but Win 7 OS Dell laptop.
From the beginning of developng my simulink model, Windows had a hard time (aka some hanging) when the Windows Explorer was used to open the folders where SLX files exist or save the SLX files to hard disk. I am not sure if the problem is a conflict with internet explorer or not but turning off the pc's internet does not help.
My model is becoming gradually large, and the hanging has been really frustrating. After any simulation which takes a few seconds, I should wait for about 2 mins or more for hanging of the system(unresponsiveness of Matlab and Simulink).
Please someone from Mathworks helps.

sfreeman on 6 Nov 2014
The problem is connected to the integration of MATLAB R2014a into the Windows Explorer. We just did some testing on several company maschines - any R2014a installation was affected. SLX size was ~ 800KB.
Call at Mathworks Support is open - I hope, they post the solution here as well.
  1 Comment
Andrew Roscoe
Andrew Roscoe on 6 Nov 2014
Great to see someone else had this - if you get my meaning. Thanks for posting that. Your experiments confirm what I seem to be seeing. Below a certain size there seems to be no issue at all, but once you go over that size it is suddenly devastating. I've had to purge my machine and all my network drives of all large slx files and re-converter them back to the old .mdl file format.

Sign in to comment.

sfreeman on 19 Nov 2014
Hi Andrew,
Mathworks points to - I will leave another comment, if it works for me, but the bugfix looks plausible for me.
sfreeman on 24 Nov 2014
Hi Andrew,
we have installed the patch and finished testing now - it fixed our problems. I did some more testing with files upto 18.6MB slx, which worked reasonable so far.
Corey Lagunowich
Corey Lagunowich on 5 Dec 2014
Thank you for the confirmation. We have updated the description in Bug Report 1068267 to clarify that the patch addresses this issue.
(To explain the discrepancy in Bug Report numbers: while the bug descriptions are different, and the attached files have a different name, the patches for Bug Report 1059612 and Bug Report 1068267 are identical as the same patch addresses all of these issues).

Sign in to comment.

Corey Lagunowich
Corey Lagunowich on 21 Nov 2014
Edited: Corey Lagunowich on 5 Dec 2014
I am from MathWorks Advanced Support. While the symptoms you are experiencing do not exactly match the description in Bug Report 1068267, I believe that the patch attached to that report will also resolve this issue.
UPDATE: This has been confirmed by another user who was experiencing the issue, and the description in Bug Report 1068267 has been revised.


Find more on Application Deployment in Help Center and File Exchange


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!