Documentation

This is machine translation

Translated by Microsoft
Mouse over text to see original. Click the button below to return to the English verison of the page.

surfview

Open Surface Viewer

Syntax

surfview(fuzzySys)
surfview(fileName)

Description

The Surface Viewer is a graphical interface that lets you examine the output surface of an FIS for any one or two inputs. You can examine an FIS that is:

  • Stored in a file using surfview(fileName), where fileName is a character vector. The FIS is stored in the file fileName.fis.

  • In the MATLAB® workspace using surfview(fuzzySys), where fuzzySys is an FIS structure.

Because it does not alter the fuzzy system or its associated FIS structure in any way, Surface Viewer is a read-only editor. Using the drop-down menus, you select the two input variables you want assigned to the two input axes (X and Y), as well the output variable you want assigned to the output (or Z) axis.

If you want to create a smoother plot, use the Plot points field to specify the number of points on which the membership functions are evaluated in the input or output range. This field defaults to a value of 101.

Click Evaluate to perform the calculation and plot the output surface.

By clicking on the plot axes and dragging the mouse, you can manipulate the surface so that you can view it from different angles.

If there are more than two inputs to your system, you must supply the constant values associated with any unspecified inputs in the reference input section.

Refer to The Surface Viewer for more information about how to use surfview.

Menu Items

On the Surface Viewer, there is a menu bar that allows you to open related GUI tools, open and save systems, and so on. The Surface Viewer uses the same File menu as the one on the Fuzzy Logic Designer:

  • Use the Edit menu items:

    Undo to undo the most recent action

    FIS properties to open the Fuzzy Logic Designer

    Membership functions to invoke the Membership Function Editor

    Rules... to invoke the Rule Editor

  • Use the View menu item:

    Rules to invoke the Rule Viewer

  • Use the Options menu items:

    Plot to choose among eight different kinds of plot styles.

    Color Map to choose among several different color schemes.

    Always evaluate to automatically evaluate and plot a new surface every time you make a change that affects the plot, such as changing the number of grid points. This option is selected by default. To clear this option, select it once more.

Introduced before R2006a

Was this topic helpful?